IAA effects, manual initialisation for each session.

Hello all, I have a question for you.

I've just been finishing off the IAA effects implementation but i've been having some trouble with IAA node zombies, as you do. Originally I wanted all IAA effects to load up automatically as you open a session. Unfortunately this is not ideal as it causes the UI to freeze momentarily if the IAA node struggles to initialise. With this in mind, I thought it would be safer to let the user initialise the IAA effects manually by tapping on the icons after a session has loaded. This means that you won't be waiting around for a session to load if you have some troublesome IAA effects.

What does every one think? Is it a pain to load all the IAA effects manually? Bearing in mind that IAA effects will only be available on the three input insert slots.

Cheers!

Comments

  • The AUM approach the best IMO. When something fails it shows red line and ask you for reload.



  • Yeh GTL does this when an IAA node fails. I just want to avoid loading them automatically when you open a session.
  • It works like AUM and it doesn't mess the session loading, seems right to my eyes.
    Maybe I missunderstood something @Jack?

    A checkbox in preferences (outside the app or splash screen) with "disable automatic IAA loading at startup" could be useful. I remember how buggy was Modstep when they implement it and made me unninstall it forever. I never come back and avoid it the most as I can :/
  • It would of course be ideal if the effects would load automatically when you load up a project, but I'd much rather that I had to press a button to make them load manually than GTL just hang up and not load because of a faulty IAA.
  • edited June 30
    It's a shame but I agree it would be a pain to have sessions hanging g all the time. Hopefully I will come up with a work around but for now, I'll leave it as manual loading. Of cause audio units will load with the session, they're much better anyway! Thanks for your input @dubbylabby, @ricksteruk.

Leave a Comment