Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Question about session start for live performance.

I want to use group the Loop in a live setting with other musicians, and am having issues with the start point of the session. With Cue off, starting the whole session hardly ever starts at the beginning of the Loop (it seems quite random where it starts!). With Cue on, I don’t have a click or count-in to know when it starts. I can put the metronome on but then have to shut it off again, and I don’t want to add extra things to turn on or off, and I don’t really want Cue on anyway, during playback. Is there a way to get the loops in a group to start at the beginning, with Cue off?

Also one other question, is there a way to overwrite a session, or resave it?

Thank you!

Comments

  • @fattigman solved my issue (ableton link was enabled) over on the audiobus forum, so thanks for that! But a question for Mr. GTL dev - is there a way to make the global play button start the loops from the beginning, while having link enabled, rather than at a random point?
  • Hi, that sounds strange. I have never had that problem. From a standing start, tapping any of the play buttons should make the session run from beat one. If you have the Master group running and you tap play on any of the other groups, then that group will start playing immediately ..but in sync with the master group.
    Are you syncing to anything outside GTL? As for the saving thing....I've never worked it out....but I think you can't either overwrite or resave.
  • Yes, it’s synced by Ableton link with some keyboard apps as I sometimes use the arpeggiators. I think it is an issue with ableton link, at least when it’s disabled the loops will all start at their start point. Ultimately I’d like to have it enabled!
  • Hi @girlvsworld, what other Link apps are you using alongside GTL? I will check them out and see if I can recreate this.

    In the meantime, try setting the 'Sync Quantum' in the 'Clock Sync' settings to 1 bar instead. This will force GTL to always sync to the next bar rather than the Ableton Link quantum. Of course the down side of this is that you have to press the play button just before the bar you want GTL to start playing on. It does however let you ignore the Ableton link quantum if something odd is happening.

    In the next update you will be able to duplicate sessions. Will this helps you out with 're-saving'.
  • Hi @Jack! Mostly just syncing it to Model 15 to use the arpeggiator. I am also running animoog and KQ Dixie at the same time but just playing midi keyboards with those. All running through AB3 for state saving on a big iPad Pro first gen. I’ll try the sync quantum tip and see if that works! It occurred to me today that I could just add a 4 or 8 count hi-hat to the first group and just play that as a count-in, although it’s another switch but should be manageable. Also, just wanted to say I think this is a great app!
  • @girlvsworld, glad you like the app! I’ve just read your post again. This sounds like normal behaviour. Ableton link has a global quantum which is shared by all connected apps. The purpose of the quantum is to ensure all apps stay ‘in phase’ with each other. E.g if you have one app running an 8 bar sequence then you press play on another app, with an 8 bar sequence, then it will wait until the end of the 8 bars before coming in.

    So if you have CUE turned off in GTL the playhead will jump straight to the global Link position in that 8 bar sequence. The down side of this is when you are running 1 bar loops on other apps. GTL doesn’t know this and will seem like it’s jumping in at random places.

    As I mentioned before, the solution is to set the ‘Sync Quantum’ setting to 1 bar then GTL should always jump in at the next bar and ignore the ableton link quantum.

    Hope this makes sense.
  • Thanks @Jack. I get you, and I understand why it’s behaving that way even though I’m not running loops elsewhere ( but I understand it’s syncing to the arpeggiator). I wish GTL could be the boss and that Cue could count in playback and then Model 15 would follow it. But I think having my own hi hat loop count-in in its own group and then switching to the start of the song in Group 2 is my only solution.
  • edited January 21
    Ableton Link doesn’t have transport sync so unfortunately you can't make one app cue in another. I like your idea to use group 1 as the count in metronome though.
  • Would it be helpful to have a count in option for global play in the settings?
  • Yes! That would be great! I played around a bit with the count-in in group 1 this afternoon and it seemed good but I’m going to do further testing tomorrow. I know you have a lot on your plate so don’t want to add any pressure ;)
Sign In or Register to comment.