Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

can´t overdub on some loops with midi bindings via nanopad2

ipad air1, ios 10.0.2, latest app versions, iconnect audio 4+, korg nanopad2, sometimes ableton link enabled and sometimes not, sometimes inside audiobus and sometimes not :
audio input:
audiobus l+r
clock sync:
longest loop, 4/4, 86 bpm
midi:
global>play stop>ch1 note 51/select previous group>note 44/select next group>note 48/play stop group>note40/
loop1 in group>rec/overdub>ch1 note 36/mute>note 39/clear>note 43
general:
algorithm>time strech

Comments

  • edited November 2016
    Hi @owi, thanks for the detailed report!

    It is possible when you have 'Time stretching' enabled that loops are processing in the background. You can tell this as they will have a loading animation over them. After every overdub the loop is actually disabled for a short amount of time while it processes however if there are other loops processing for 'time stetch' in the background then this overdub processing will slow down significantly and as a result leave the loop disabled until it has finished.

    Do you think this is what you are experiencing?
    Try turning 'Time Stretch' algorithm off and using pitch instead to see if this resolves the problem.
    Also when this happens, are you able to overdub manually by tapping the screen or is the loop UI disabled?

    Cheers
  • owiowi
    edited November 2016
    Jack wrote: »

    Do you think this is what you are experiencing?
    Try turning 'Time Stretch' algorithm off and using pitch instead to see if this resolves the problem.
    Also when this happens, are you able to overdub manually by tapping the screen or is the loop UI disabled?

    Cheers

    that´s it. in pitch change mode everything seems to be ok now. thanks for your help.
    i´ll get into it a little deeper now. nice app!

    ...but when i overdub or record the next loop without ´cue´, sometimes i can hear the playback of the previous loop
    for a short time. that should not be i think.
  • ... sometimes i can hear the playback of the previous loop in the previous group...
  • edited November 2016
    Think I know what you mean, I'll look into it.

    Also I've just added a tiny processing animation to the bottom left corner of loops. This will appear when a loop is processing after an overdub so you know that the loop is disabled for awhile.
Sign In or Register to comment.