Guitar>AUM input>IAA>GTL bug? (Solved)

edited October 2016 in Bugs
Hi, I'm struggling to get any results with the above setup. I hear and see my signal going into GTL but after recording there's nothing recorded. In AUM I created a track with my audio interface as input and IAA port 1 selected as output. In another channel I selected GTL as input and the interface as output. Then in GTL I selected AUM port 1 under IAA input. Is there a bug or am I doing something wrong? Recording directly from the interface into GTL works... Any ideas?


  • edited October 2016
    Hi @munibeast, thanks for spotting this. I've recreated your setup my end and it records fine so it sounds like a hardware related bug to me.

    It would be really great if you could run some tests for me to try see where the problem lies.

    1. Try your exact setup but without an audio interface, using the iPad mic and speakers. Are you able to record into GTL now?

    2. Remove GTL from the input of channel 2 in AUM. You should be left with your interface in the input slot and the GTL IAA node in the output slot of channel 1. Are you able to record into GTL now?

    3. Connect GTL to an input slot in AUM only. Can you record now?

    If you're up for it, It would be great to do some beta testing together to try and crack this?

  • Hey Jack, thanks for getting back to me so quickly!
    I tried everything except 1. so far, now with an iRig HD instead of the Apogee One I had been using previously. It's similar except that now the recording is not empty but a high pitched noise (the one that sometimes occurs when there's some kind of error because an app that's supposed to play in the background is suspended...
    I'd like to do some beta testing. And I'll also try idea 1. later.
  • Tried with the mic and speakers as well now with the same results: Annoying error sound. Same thing on iPad mini 4 and iPad Pro 12.9", iOS 10.0.2
  • Thanks @munibeast, that's useful to know. I will mull it over and try and come up with some potential solutions then send a beta out for you. I believe you are already a tester?

    Is it like a high pitched buzzing? This usually happens in IAA when measurement mode is turned on or an app that uses measurement mode is opened like GTL. Relaunching everything usually resolves the problem though.

    Are you using any other apps or effects in AUM with this setup?

    Thanks for offering to help, much appreciated!
  • I thought I'd try a higher buffer setting in AUM and got it working now with 128 samples. I had it set to 64 before when it didn't record properly. So I guess 128 is the minimum latency for now. Cheers!
  • edited October 2016
    Glad you got it sorted! Also make sure that AUM is set to 44.1kHz and 16bit in the settings.
Sign In or Register to comment.