Skip to content

Routing audio

Could someone explain how to route audio from another app into the looper? I've got audiobus and AUM on a new ipad and am struggling...this is the main reason I bought the ipad. Maybe the software doesn't function well on new M1???


  • edited June 2021

    Hi @Elevenses, are you seeing any errors?

    Audiobus is fairly easy to setup. Just load Group the Loop into the 'output' slot. Any app in the input slot will be recorded to GTL.

    If you want to hear the input then you will need to turn on input monitoring.

    For AUM you will need to send your audio to an IAA output port then select this port as an input in GTL.

  • Audiobus method causing weird feedback delay when used with Geoshred. It might be the M1 platform...have you made sure GTL functions like this on the new ipad?
  • I want to leave a picture - is there a Facebook forum to load video so I can demonstrate the buginess with geoshred?
  • I think audiobus isn't updated for M1 might have to return m1 and get older model
  • No the issue is also gtl...crashes whenever I load geoshred as input
  • edited June 2021

    Thanks @Elevenses, feel free to send any videos to this email:

    I wouldn't expect the M1 chip to cause these problems although I don't have an M1 device myself to test so I can't say for sure.

    Are you able to connect any other apps together successfully, not including GTL? It would be useful to know if GTL is causing the issue or if it's a OS bug with Inter-App Audio that affects all apps.

  • ...thanks and how can I do multiple inputs in AUM?
  • Right so I have geishred and drumcomputer routed into aum port 1 and port 1 as input in gtl but still no sound when monitoring??
  • My only thought it i haven't been using headphones ill try once interface and hub have arrived.
  • @Elevenses said:
    Right so I have geishred and drumcomputer routed into aum port 1 and port 1 as input in gtl but still no sound when monitoring??

    Sounds like progress, not sure why you can't get monitoring to work. Have you checked volume on the iPad is up. Also make sure you have given GTL permission to use the microphone in iPad's settings.

  • edited June 2021

    @Elevenses said:
    ...thanks and how can I do multiple inputs in AUM?

    Not possible I'm afraid, you will need to submix your instruments/inputs to a bus in AUM and then route its output to GTL. Basically you use AUM as an input mixer to GTL.

  • Thanks Jack. Now I finally managed to loop audio from geoshred its really glitch and the quality is dreadful (sent you an email with it). I think I'm going to surrender with this new ipad. And go for a model that does what I need albeit older. Can you please suggest the ideal model for optimum use with gtl?

    Do u happen to know what ipad trellis (James) used??

  • edited June 2021

    Thanks @Elevenses, appreciate all the info you've provided on this.

    I use an iPad Pro 10.5 for development and it works great. Any newer non M1 iPad will work just fine though.

    My biggest question: Can you get any other apps to work in Audiobus? or is it just between GTL and GeoShred?

  • As I said in the other topic it could be something related to iPadOS version. Everytime Apple releases an update wrecks some things that were working flawless in the process.

    Also check forums to see if the problem is AB3 or geoshred and also try to explain your whole workflow so anyone trying to help you can see if there isn’t “a common mistake” (like using looper apps without headphones and expect crystal water recordings or similar).

    Finally... live looping is an experimental field. Even when apps like GTL or around-the-corner loopy pro it means users need to study deeply many topics such audio routing, midi/link sync, platform regular issues (as exposed) or hardware limitations (that includes iPads as hardware but also Roland RCs in slave mode to point an example) etc etc.

    Even with the most expensive solution on the market (Aeros?) you will find some issues due the nature of the field and expertise comes with that “knowledge journey” so if you want to go fast route consider getting some courses or 1to1 class instead believing is “just plugnplay” because pro users make it seem easy. It isn’t and also requires talent (good timing, good ear, patience, stress management when things wreck without a reason in the middle of a gig...)

    Tool used is just small part of the field. Don’t get discouraged but prepare yourself for struggle. Live looping isn’t for everyone or standard methodology.

  • New GTL user here but had a fun looping session with a M1 iPad today using Synth One as my sound source plus loops from Splice. Great experience. Maybe Geoshred is the issue? Not familiar with it.

  • edited June 2021

    Hey @cdub,

    Very glad to hear that, thanks for taking the time to post. Yes maybe something else is at play here...

Sign In or Register to comment.