Skip to content

GTL worked once now crashes on opening - FIXED

edited July 2021 in Help

Today I installed GTL on my 2018 iPad. It seemed to be working well, I had 2 tracks recorded though my irig2 input but then it suddenly crashed. Now when I try to open it, I see the logo for a few seconds whilst it says "loading session" but then takes me back to iPad home screen. I have restarted the iPad several times and tried without the irig plugged in.

I'm not used to iOS so I may be missing the obvious, any ideas please?



  • edited July 2021
    Hi @pipp1, sorry about that. Sounds like a session file is corrupted.

    If you’re not precious about your GTL sessions then just delete GTL from your device and reinstall it from the App Store. It will delete your sessions so let me know if you want to keep them and we’ll work out a solution.

  • Thanks, what would be the process to try to keep the session please?

  • Plug your iPad into a computer and find the GTL documents folder. Drag the whole folder called sessions over to your desktop. You’ll find the individual audio files stored under the session name. If you need to recover your session’s and settings then send the whole folder to me at and I’ll see what I can do.
  • edited July 2021
    How to transfer your files. Ignore the part about icloud.
  • edited July 2021

    Just looking into this, hopefully I've fixed the bug.

    Installing the beta may solve the crashing for you. Just let me know your email if you're interested.

    Thanks for sticking with me!

  • edited July 2021

    Morning all, this is fixed now in version 2.0.5. Update if you have't already. Thanks for reporting it @pipp1!

Sign In or Register to comment.