Distorted audio coming from Beatmaker 3 into GTL.

I am getting distortion on my signal coming in from Beatmaker 3. Anybody have any idea how I can fix that?

Comments

  • Hi @Zendrik, how are you connecting beatmaker? Audiobus, AUM, directly as an IAA input?

    Might be worth closing all apps and reconnecting your interface to see if that helps. Also do you get the same distortion if you unplug your interface and play through the iPad speakers?
  • Thanks so much. I have been connecting directly, and yes the distortion is still there when I play through the ipad speakers. I have downloaded Audiobus, but have not figured out how to use it. Some tips would be greatly appreciated.

  • AUM looks a bit easier and useful, would you recommend I use that instead? Thanks for a great product. GTL is perfect.

  • edited November 8
    Audiobus is certainly easier to use, AUM has more routing flexibility. I would definitely start with Audiobus. Meanwhile I will look into the beatmaker issue myself.

    Have you tried increasing the buffer size in group the loop? Go to Settings -> Audio Settings and change the buffer size to “1024 frames”. If this value is too low then the audio may dropout/glitch.

    Cheers
  • Hi again @Zendrik, I've just been looking into this issue. I seem to recall having problems with Beatmaker and GTL before but I don't think there is anything I can do about it as other IAA apps seem to work fine in GTL.

    Here are a couple of things you can do to make the setup smoother.
    1. Force close everything including GTL.
    2. Open Beatmaker 3 first.
    3. Make sure "Background Audio" is turned on in Beatmaker's settings. Without this Beatmaker will disappear when you bring GTL to the foreground and you may get a horrible buzzing.
    4. Then open up Group the Loop and set Beatmaker 3 as the audio input.

    Hope that helps.

Sign In or Register to comment.