Praise and a question

edited January 1970 in General Discussion
I just acquired Group The Loop and I'm really impressed. I love the concept, the user interface is clean and well structured, it's simple to use yet very powerful. You even seem to have figured out the crossfading really well. So, well done and thank you for this little gem.<br /><br />There is one thing though that hasn't worked the way I wanted on my first try: I've configured the 8 pad buttons of my Akai LPD8 to control some functions of the app. I want the first button that sends a Note On 60 when I press it and a Note Off 60 when I release it to record and overdub the selected loop and also to clear it when I keep it pressed. So I've assigned the record/overdub function to Note 60 (Tap) and the clear function to Note 60 (Hold). But when I now tap the button both functions are immediately triggered. The loop is cleared before it even starts recording (with cue on). Am I doing something wrong or is this a bug?<br /><br />Thanks in advance,<br />Axel


  • Hey Axel, thanks for the kind words, makes it all worth while! :)<br /><br />Sorry you are having trouble with MIDI, I can't seem to reproduce this my end. Are you holding down the trigger pad to record? Or maybe the Akai is in latching mode rather than momentary? The GTL MIDI hold function works by counting the time between the MIDI note on and MIDI note off commands, so if you hold down the trigger pad or have your device in latching mode then GTL will record and then reset after about 2 seconds. This is because it has not received the note off command. Is this the behaviour you are getting or is the loop resetting instantly? If the latter then this could be a bug in GTL specific to the Akai LPD8.<br /><br />Cheers,<br />Jack
  • Hi Jack,<br /><br />I've tried again and it shows the same behaviour: the timer of the clear function is not reset by the note off. I monitored the midi coming in from the LPD8 in MidiFlow and everything looks normal: The note off is sent when I release the pad. The LPD8 has velocity sensitive pads so the velocities it sends are rather unpredictable. But that shouldn't play a role. Or should it?<br /><br />I also tried a different controller and everything worked as it should. There seems to be an LPD8 specific issue. If you're interested I could send you a text file with some sample output of the controller.
  • Thanks Axel, really great feedback. I suspect it is velocity related as you suggested. If you could email me a text file of the LPD8 MIDI output that would be great.<br /><br />Cheers
  • Hey Axel, pretty sure i've fixed the MIDI hold command issue now. It will be working correctly in the next update which is due very soon. Thanks for your help!
  • Ha, you have indeed sorted it out! Fantastic! Thanks a lot!
  • edited October 2016
    "x2l wrote:
    Ha, you have indeed sorted it out! Fantastic! Thanks a lot!
Sign In or Register to comment.